PSI International

Operating system not supported


The operating system (OS) you are using is not supported by ATLAS Cloud.


  • Candidates: Ask the Test Administrator for assistance.
  • Test Administrators: Make sure the computer has one of the supported OSs installed, and that it is updated to the currently supported version. See the ATLAS Cloud System Requirements for more information.
Have more questions? Submit a request