PSI International

Javascript unable to call Java


A security setting is blocking access from the webpage to the java applet. This must be allowed for the tests to work.

If using Java 1.7.0, the following causes for this are known:

  • In the Java Control Panel, on the Security tab if the Security Level is Very High this blocks. It must be High or lower.
  • If using a version at or above Java 1.7.0_25 then your installed version may have become replaced by a more recent one. Oracle have a restriction where older versions of the java plugin stop working when an updated Java version becomes available. This check is not done if the Security Level is Medium.

Note: Changing security level should only be used as a temporary workaround. We recommend updating to the latest version.

Note: A browser restart may be required after changing Security Level.

Have more questions? Submit a request